Linux SoundJack Installation

Habe die aktuelle Debianversion. Natürlich sind die libraries nicht verfügbar, mache also den Schritt, wie in den FAQ angegeben:
apt-get install …/libQt5Multimedia.so.5
nit dem Ergebnis:
E: Unsupported file …/libQt5Multimedia.so.5 given on commandline

was tun?

Update:
habe die Bibliotheken als root in das entsprechende Verzeichnis kopiert mit dem Ergebnis nach dem Aufruf soundjack.sh:
Cannot mix incompatible Qt library (version 0x50501) with this library (version 0x50701)
Aborted

Hi Toni,
vielen Dank!
Das war wohl leider nicht die gesuchte version die du rein kopiert hast - das sollte natürlich alles apt[itude] richtig machen.
Wir werden den Qt Installer nochmal checken und uns melden.

Hallo,
offensichtlich richtig. aber das apt hat ja nicht funktioniert … es gibt eben zu viele Versionen von Linux. Danke dass ihr euch kümmert.

Ich habe dasselbe Problem!
ich bekomme soundjack auf meinem NUCi7 mit ubuntu nicht zum fliegen. Er sagt er könnte eine im selben Verzeichnis liegende Lib libQt5MultimediaWidgets.so.5 nicht finden. PATH hab ich erweitert und exportiert. Muss ich sonst noch was machen nach dem Auspacken.
Er sagt er findet libQt5MultimediaWidgets.so.5 nicht.

Im FAQ steht:
The current download most likely does not contain all the required libs (e.g. libQt5MultimediaWidgets.so.5), however, you can still run it by manually installing these missing libs via " sudo apt-get instal ". (-> der Typo bei instal steht im FAQ - ist nicht von mir)

sudo apt-get install libQt5MultimediaWidgets.so.5
Paketlisten werden gelesen… Fertig
Abhängigkeitsbaum wird aufgebaut.
Statusinformationen werden eingelesen… Fertig
E: Paket libQt5MultimediaWidgets.so.5 kann nicht gefunden werden.
E: Mittels des Musters »libQt5MultimediaWidgets.so.5« konnte kein Paket gefunden werden.
E: Mittels regulärem Ausdruck »libQt5MultimediaWidgets.so.5« konnte kein Paket gefunden werden.

Muss da vielleicht noch was in /etc/apt/sources.list oder in /etc/apt/sources.list.d/ eingetragen werden, das vergessen wurde zu erwähnen?

Hat das irgendjemand zum fliegen gekriegt?

Habe es vorgestern in den Griff bekommen.
Befehle:
apt search … die Dateien
dann
apt install … die Ausgabe der Suche - Groß- und Kleinschreibung beachten. dann gehts.

1 Like

magst du für die anderen den string statt … nochmal raussuchen? Danke!

Also bei mir ist das apt search sehr übersichtlich. Ich bin ja naturblond, aber ich finde da nichts was ich installieren kann. :wink:
petra@petra-nuc:~/SoundjackLinux$ sudo apt search libQt5MultimediaWidgets.so.5
Sortierung… Fertig
Volltextsuche… Fertig
Was steht denn da bei Dir?

Habe das jetzt auf einem zweiten Rechner gemacht. Zuerst die Linux Version aktualisieren, dann sollte die Ausgabe von search die Dateien ausgeben, die du mit install installieren kannst.

ich hatte jetzt ein anderes Problem, wie auch schon unter Windows - am Tag der Installation klappt es, 2 Tage später nicht mehr. Habe da aber im IRC Kano angefragt, was er sagt.

Leider ist der Rechner hier nihct der, den ich zum betreiben von soundjack nutze
daher ist das kopieren sehr kompliziert :wink:

Hallo Toni,
die Linux version war vorher schon taufrisch, weil ich ein sudo do-release-upgrade hab drüber laufen lassen.

Um soundjack auf Ubuntu 18.04.4 LTS (bionic) zum laufen zu bekommen muss man folgendes tun - wobei einem weder das FAQ noch die Installationsanleitung irgendwie beisteht es herauszufinden:

sudo apt-get install libqt5multimediawidgets5
sudo apt-get install libqt53dcore5
sudo apt-get install libqt5websockets5

Bitte folgenden Artikel einmal lesen:


Und dem dort enthaltenen folgenden Ratschlag bitte folgen! :wink:

It may be simplest to package the project using Ubuntu’s package management system. The Qt dependency will then be automatically installed by the package manager when your project is installed. That’d be the best way to go about it, as long as there is a version of Qt 5 available in Ubuntu’s package repository. It’ll save you a whole lot of grief."

also ich habe das neue Kanotix … ist auch n Debianclone.
nachdem ich ein upgrade gemacht hatte, hat der apt search die dateien ausgegeben, vorher nicht. und dann war auch die installation möglich.

bei mir gibt search nichts aus bei keiner dieser libqt5* Dateien durch die ich mich durchhangeln musste. Ich hab mir das auf Ubuntu Paketservern ergoogelt in Salamitaktik.

Ich bin aber nicht alleine, da sind tonnenweise Fehlermeldungen von diverser anderer Software, die dieses Qt Pakete verwendet und genau diese Fehlermeldung hat von irgendwelchen Komponenten libqt5*, und die erfolglos mit ldd experimentiert haben. Das macht es eher unwahrscheinlich das es an meiner Maschine liegt.
z.B.
https://newsgroup.xnview.com/viewtopic.php?t=32662

Da hast Du wohl eher Glück gehabt.

Und zu früh gefreut. Eben auf die 0524er Version upgegraded und das Portforwarding auf 50050 umgestellt, ich kann mich wie vorher zum Mirror connecten brauche aber statt 128 einen 512er Netzwerk und Samplebuffer, kann dann so eine Minute was hören, dann verschwindet die Latenzanzeige hinter der Zeile und Audio ist tot. Firefox+Audiojack abschiessen und neu, wieder das selbe in 5-6 Versuchen.

da hatte ich ein ähnliches Problem. hast du die neueste version für linux runtergeladen? da gibbet eine neue

OK, habe gesehen ja - guck mal in die programmleiste, ob SJ schon läuft - wenn ja beenden und in der reihenfolge SJ browser neu öffnen